当前位置:首页> 学堂>指标>MACD >正文

第一次有人把“MACD8字精华”说透了:“买小卖小,缩头缩脚”,别再傻傻的金叉买死叉卖了

2019年11月08日 21:10:59 来源: 财富动力网综合

MACD有八字真言“买小卖小,缩头缩脚”小指的是,红绿柱的堆而言,缩头缩脚是指红绿柱的长短而言。当股价一波比一波高时,反而红柱的堆,一堆比一堆小,证明产生了顶背离现象,应该及时卖出;当股价一波比一波低时,反而绿柱的堆一堆比一堆小,证明产生了底背离,应该买进。

*红柱缩短:股价即将回调,对应策略是高抛。

*红柱加长:股价将连续上涨,对应策略是持有。

*绿柱加长:股价将连续下跌,对应策略是空仓。

*绿柱缩短:股价将止跌企稳,对应策略是中线资金进场低吸,一般都可以买在相对的低位。

*红柱翻绿柱=进入空头市场,后期走势以跌为主。

*绿柱翻红柱=进入多头行情,后期走势以涨为主涨。

案例

需要注意的问题:

当MACD还是绿柱的时候,且绿柱一天比一天短,即将变成红柱的时候买进,要求红柱还没有出来,但是绿柱已经缩小的差不多的时候,其含义是在空方没有还手之力的时候,多方很容易对这个股票发动攻击行情。还有就是为了过滤骗线以及伪信号,必须也得看前期的行情是否符合条件。

MACD红绿柱长短的秘密,极少人知道!

对于能量转化来说,我们用当前最近的两块红柱面积和两块绿柱面积的大小对比,就可以哦按段出当前所处强弱状态。这四块红绿柱面积得分析,我们称之为能量的四元动态分析,四元的元素定义如下:

红最近:当前最近的红柱面积;

绿最近:当前最近的绿柱面积;

红次近:当前次近的红柱面积;

绿次近:当前次近的绿柱面积。

相关定义可参考下图:

红最近大于红次近,表现为做多力量偏强;

绿最近大于绿次近,表现为做空力量偏强;

红最近小于红次近,通常表现做多的力量偏弱,即为顶背离;

绿最近小于绿次近,通常表现做空的力量偏弱,即为底背离;

当红最近非常小(甚至于没有红柱),远远小于红次近时,做多力量往往会转化为做空,即为彻底顶背离;

当绿最近非常小(甚至于没有绿柱),远远小于绿次近时,做空力量往往会转化为做多,即为彻底底背离;

总之,无论对于上升、震荡、下降趋势的股票来说,红越大,绿越小,其强势的特征就越明显;红越小,绿越大,其弱势特征就越明显。

最强特征:红最近>红次近>绿次近>绿最近;

次强特征:红最近>绿次近>红次近>绿最近;

最弱特征:绿最近>绿次近>红次近>红最近。

其余情况依此类推。

关于股票买入点,通常要选择当前是绿柱,并且绿最近很小,且跌势趋缓(次级别出现底背离)买入。

关于股票卖出点,通常选择当前红柱,并且红柱近期小于红次近,且涨势趋缓(次级别出现顶背离)卖出。

对于那些出现彻底顶背离的股票,要坚决离场,因为大多数情况,其后杀跌的力量会很强;少数化解的情况,以后的文章会做分析

对于那些出现彻底底背离的股票,不一定要介入,因为有很多下跌趋势的股票,反弹很弱,其后还会继续下跌;除非是大级别(周线)运行在上升通道中,并且无顶背离,本级别(日线)出现彻底底背离,这种情况就可以介入。

走势是不断演化的,红最近、绿最近、红次近、绿次近这四元素也会不断的演化,演化结果就是不断产生新的强势走势、弱势走势、顶背离、底背离等。弱势走势出现时卖出。强势走势出现时买入。动态思维来分析当前形式,这才是能量的四元动态分析精髓。

利用MACD能量柱逃顶、抄底:

1、逃顶

案例讲解:洪涛股份

标注点1:红柱不断增强之后第一次能量柱衰退,不再创新高,所对应的股价重心回落;

标注点2:红柱不断缩短,同时DIF与DEA形成了死叉,所对应的股价为阳十字星;如果你按照死叉卖出的原则 明显滞后(相对点1);红柱不断缩短由红变绿(相对点1更加晚了)也是滞后。

MACD,金叉买入死叉卖出的交易策略,显得之后,那我们要克服MACD滞后盲点,如何规避盲点呢?利用物极必反的原则(做多能量冲至最顶级时,没办法再增强时要走下坡路了)

红色能量柱由短到长增强之后第一次衰退,所对应的如果是阴阳十字星的话,那么构成阶段性高点的概率就非常大,这是第一点。

红色能量柱由短线到长增强之后第一次衰退,所对应的股价如果阴线的话,那么构成阶段性高点的概率也很大,这是第二点。

红色能量柱由长变短有可能是反弹中继,如果是反弹中继,在股价重新高之后重新做多介入。

案例说明2:东睦股份

标注点1:红色能量柱物极必反,重心回落第一个交易日所对应的是重点回落的阴线,仍然有可能会产生高点,我们就要进行风险控制了。

标注点2:没形成死叉,也没有红翻绿过渡,那么点1处于调整,有可能是反弹中继调整。

标注点3:3为阴线所对应的红柱缩短,因此,构成了阶段性买点,类似于大级别高点。

标注点4:死叉,由红翻绿,回头看看点2点3点4没有理由继续留下该股;

2、抄底

抄底与逃顶相反

在底部,物极必反的绿色能量柱开始缩短所对应的股价如果是阴阳十字星,那么构成阶段性低点的概率就很大,所对应的位置就是买点,这是其一。

其二,在底部,物极必反的绿色能量柱开始缩短所对应的股价如果是小阳线,那么构成阶段性低点的概率很大,所对应的位置就是买点。

在底部,绿色能量柱由长变短有可能是下跌中继,如果是下跌中继,股价创新低之后重新做空。

案例:云海金属

标注点1:能量柱释放到了极值之后,物极必反,绿色能量柱开始缩短,所对应股价呈现一小阳线。

在底部,物极必反的能量柱所对应的小阳线(十字星也可以),对对应的位置就是买点。

标注点2:DIF上穿DEA形成了金叉,能量柱由绿翻红,这个位置可以抄底,但是逃不掉MACD的滞后盲点。

在点1位置最好,点2的位置滞后点加仓。

案例:中科三环

标注点1:根据红色能量柱物极必反原则,在点1这点,红柱缩短,所对应高位十字星,那就是顶部结构。

标注点2:调整之后的点2,绿色能量柱是物极必反产生得小阳线,可买入。

标注点3:零轴之上一次金叉,能量柱由绿翻红,这是加仓点。

标注点4:零轴以上二次金叉,和点3相比,点4为二次金叉,容易产生大级别反弹行情,这是进一步的加仓点,可博取后市反弹的利润。

“MACD看透主力”初始版:

1.底背离、低位金叉、二次金叉,还有双金叉(低位金叉和二次金叉)、三全项(底背离、低位金叉和二次金叉);

2.增加主力做坐庄四部曲:主力吸筹、主力拉升、主力派送和主力砸盘,主力行为一目了然;

3.把DIF线做成可以变色的线,主升浪时是红色线,主跌浪时是绿色线;

4.柱体也可以做出更多的颜色,零轴以下的不说了,零轴以上的,细分为黄金柱表买入、红柱表持有、绿柱表卖出。

“MACD看透主力”优化版:

用法:

1.主力拉升、底背离、低位金叉、二次金叉、双金叉和三全项,可以买入;

2.在0轴以上出红色MACD柱,主力拉升=1,建议持有;

3.在0轴以上出绿色MACD柱,主力拉升=0,坚决卖出。

超强MACD看透主力更新版公式指标公式源码:

VA:=IF(CLOSE>REF(CLOSE,1),VOL,-VOL);

OBV1:=SUM(IF(CLOSE=REF(CLOSE,1),0,VA),0);

OBV2:=EMA(OBV1,3)-MA(OBV1,9);

OBV3:=EMA(IF(OBV2>0,OBV2,0),3);

MAC3:=MA(C,3);

SHORT:=12;LONG:=26;MID:=9;

DIF:EMA(CLOSE,SHORT)-EMA(CLOSE,LONG)COLORYELLOW ;

DEA:EMA(DIF,MID)COLORFF9900 ;

MACD:=(DIF-DEA)*2;

STICKLINE(OBV3>REF(OBV3,1) AND MAC3>REF(MAC3,1),0,MACD,2,0),COLORYELLOW;

吸:=XLPL.NOTEXT吸;

拉:=XLPL.NOTEXT拉;

派:=XLPL.NOTEXT派;

落:=XLPL.NOTEXT落;

STICKLINE(吸,0,MACD,1,0),COLORLIRED;

STICKLINE(拉,0,MACD,1,0),COLORRED;

STICKLINE(派,0,MACD,1,0),COLORGREEN;

STICKLINE(落,0,MACD,1,0),COLORWHITE;

入1:IF(DIF>REF(DIF,1),DIF,DRAWNULL),COLORRED,LINETHICK2;

入2:IF(DIF

低位金叉:=CROSS(DIF,DEA) AND DIF<-0.1;

STICKLINE(低位金叉,0,0.08,6,0),COLORFF00FF;

DRAWTEXT(低位金叉,0.16,' 低位金叉'),COLORWHITE;

JCCOUNT:=COUNT(CROSS(DIF,DEA),BARSLAST(DEA>=0));

二次金叉:=CROSS(DIF,DEA) AND DEA<0 AND COUNT(JCCOUNT=2,21)=1;

STICKLINE(二次金叉,0,0.06,6,0),COLORFFCC00;

DRAWICON(二次金叉,DEA*0.9,1) ;

DRAWTEXT(二次金叉,0.2,' 二次金叉'),COLORYELLOW;

A1:=BARSLAST(REF(CROSS(DIF,DEA),1));

底背离:=REF(CLOSE,A1+1)>CLOSE AND DIF>REF(DIF,A1+1) AND CROSS(DIF,DEA);

STICKLINE(底背离,0,0.03,6,0),COLOR00FF00;

DRAWTEXT(底背离,0.12,' 底背离'),COLORFF00FF;

A2:=BARSLAST(REF(CROSS(DEA,DIF),1));

顶背离:=REF(CLOSE,A2+1)DIF AND CROSS(DEA,DIF);

DRAWTEXT(低位金叉 AND 二次金叉 AND 底背离,0.25,'三全项'),COLOR0000FF,LINETHICK2;DRAWTEXT_FIX(C>O,0.01,0.9,0,' WWW.CXH99.COM '),COLORRED;

DRAWTEXT_FIX(C>O,1,1,0,'程序化交易模型'),COLORRED;

DRAWTEXT_FIX(C>O,0.01,0.9,0,' WWW.CXH99.COM '),COLORRED;

DRAWTEXT_FIX(C>O,1,1,0,'程序化交易模型'),COLORRED;

想了解更多目前A股阶段的操作技巧及公式代码,或有任何疑惑,可关注公众号越声攻略(yslc688),更多后市操作及股票技术分析方法等你来学习,干货源源不断!

交易之路是一场修行,唯有“坚持”,方能抵达终点!

我们知道金融投机很难成功,这是共识。因为它对交易者的要求特别高。最重要的是,大多数要求违反人的本性,给人带来痛苦,而不是愉悦。没有人可以舒舒服服地躺在椅子上,点几下鼠标,就轻松地赚钱。也许你经过种种努力,好不容易搞清了做交易需要具备的种种条件,做好了面对一切困难的准备,但操盘所带来的多重人性考验,将超乎你的预料,你可能还是坚持不下来。

从你选择入市交易的那一天开始,你就走上了一条修行之路,也是一条苦行之路。在这条修行路上,有重重关卡,你需要一关一关过。事实上,很多关卡是你自己“设置”的,你需要战胜对交易不利的固有的本性。而坚持,是交易的最后一道关卡,无数摸爬滚打多年的操盘手,在“坚持”这一关卡前,心灰意冷,迷失了自己,从此与成功无缘。

无法坚持下去的原因,主要来自于人的逐利性。在行情不利于自己时,人人都想有所改变,而不是傻乎乎地等着亏钱。趋势型的交易者,需要在大多数时间里,忍受不能赚钱的事实。因为趋势不是时时存在,他需要等待属于他的那波趋势。这个过程可以用一个“熬”字来表达,不过,大多数所谓的趋势交易者无法熬过这一阶段,开始寻求别的出路,开始频繁交易,进而迷失了自己。只有其中一小部分人“熬”了下来,等来了趋势,实现了盈利。在趋势交易中,坚持是非常重要的一个环节。即使你的资金管理再好,你的进出场水平再高,坚持不到最后,终归是空谈。

不能“坚持”下去的原因,还包括沮丧、痛苦、失落、煎熬、羡慕等众多负面情绪带来的痛苦与不适。而能否坚守自己的策略,坚信自己的付出,坚持按照自己的方法来进行交易,是一个重大考验。有时候,你要坚持的交易会让你非常痛苦。比如,别的方法都在赚钱,而你的方法在回撤;别的市场都在赚钱,你的市场毫无起色;他人的资金曲线在创新高,唯有你的曲线在寂寞地横盘。能否坚守自己的本心,坚持自己的交易,是业余交易者与职业交易者的一个本质区别。

市场从来不缺乏盈利者,无论何时,市场上总有一些人能实现了几倍几十倍的暴利。殊不知,盈利常有,而长久的稳定盈利则少有。并且也有一些交易者,在实现了巨大利润之后,最终又以失败收场。所以,能实现长期稳定收益的交易者,一定是坚持自己的策略并且稳定实施的交易者。不过,在此过程中,有太多痛苦,太多诱惑,难以坚持。但也正是坚持,才能将业余和职业分开;也正是坚持,才有了赢家和输家;也正是坚持,验证了你对自己理念的忠诚,对自己人生的掌控。

(以上内容仅供参考,不构成操作建议。如自行操作,注意仓位控制和风险自负。)

声明:本内容由越声攻略提供,不代表投资快报认可其投资观点。

【免责声明】本文仅代表作者本人观点,与财富动力网无关。财富动力网站对文中陈述、观点判断保持中立,不对所包含内容的准确性、可靠性或完整性提供任何明示或暗示的保证。请读者仅作参考,并请自行承担全部责任。

0条评论

网站导航
股票问答