当前位置:首页> 学堂>指标>MACD >正文

2年内从亏损70多万到获利近460万,我只坚持我的:超强“MACD看透主力”!附指标公式源码

2019年11月19日 17:10:56 来源: 财富动力网综合

MACD称为指数平滑异同移动平均线,用来跟踪股价运行趋势、研判股票买卖时机的技术分析工具,从双移动平均线大发棋牌红黑而来,由快的移动平均线减去慢的移动平均线。该指标是投资分析软件中的常用指标,有“指标之王”的美誉。

它由长线均线MACD,短期的线DIF,红色能量柱(多头),绿色能量柱(空头),O轴(多空分界线)五部分组成。

DIF线:收盘价短期、长期指数平滑移动平均线间的差

DEA线:DIFF线的M日指数平滑移动平均线

0轴:重要的多空分界线。

上了0轴的股票说明了一个事实,那就是它已经由弱转强了,完成了趋势的扭转。事实上,MACD上0轴的过程,就是股价站上均线的过程。因为大家不要忘记,MACD的设计思路就是对均线的一个平滑优化。细心的朋友可能会发现,MACD和0轴的关系与股价和MA60的关系大体一致。MA60压在头顶上当然操作起来不爽啦,所以在0轴之上根据MACD进行操作,相当于在一个均线发散多头的市场中赚钱,风险将大大降低。

MACD的运用法则:

1、DIF向上交叉MACD视为买进信号;

2.DIF向下交叉MACD视为卖出信号;

3、短期内DIF从低档二次向上交叉MACD,视为强烈买进信号;

4、短期内DIF从高档二次向下交叉MACD,视为强烈卖出信号;

5、当股价的高点比前一波的高点高,而MACD的高点却比前一波的高点低时称为“牛背离”,暗示股价很快会反转下跌;

6、当股价的低点比前一波的低点低,而MACD的低点却比前一波的低点高时称为“熊背离”,暗示股价很快会反转上涨。

神奇用法:

第一步:如将MACD区间等分0~100,其中关键分界线如同KDJ或者RSI指标一致,有:20/80、30/70的分界线,当快线处于30数值线以下的时候,快线上穿慢线,并且伴随MACD能量柱有所衰减,这个时候符合了超卖区域、金叉、能量柱收缩三大法则,属于上等金叉,多头买入建仓信号:

三星半(当快慢线和能量柱处于20数值线以下的时候,买入信号更强:四颗星):

二:同样如第一步所示将MACD区间自行划分0~100均等,当快线和慢线都处于30数值线以上的时候,快线下穿慢线,并且伴随MACD能量柱有所衰减,这个时候符合超买区域、死叉、能量柱收缩三大法则,属于上等死叉,空头卖出建仓信号:三星半(当快慢线):

高级用法:

“MACD看透主力”初始版:

1.底背离、低位金叉、二次金叉,还有双金叉(低位金叉和二次金叉)、三全项(底背离、低位金叉和二次金叉);

2.增加主力做坐庄四部曲:主力吸筹、主力拉升、主力派送和主力砸盘,主力行为一目了然;

3.把DIF线做成可以变色的线,主升浪时是红色线,主跌浪时是绿色线;

4.柱体也可以做出更多的颜色,零轴以下的不说了,零轴以上的,细分为黄金柱表买入、红柱表持有、绿柱表卖出。

“MACD看透主力”优化版:

用法:

1.主力拉升、底背离、低位金叉、二次金叉、双金叉和三全项,可以买入;

2.在0轴以上出红色MACD柱,主力拉升=1,建议持有;

3.在0轴以上出绿色MACD柱,主力拉升=0,坚决卖出。

 
 
 
 
 
 
 
 

超强MACD看透主力更新版公式指标公式源码:

VA:=IF(CLOSE>REF(CLOSE,1),VOL,-VOL);

OBV1:=SUM(IF(CLOSE=REF(CLOSE,1),0,VA),0);

OBV2:=EMA(OBV1,3)-MA(OBV1,9);

OBV3:=EMA(IF(OBV2>0,OBV2,0),3);

MAC3:=MA(C,3);

SHORT:=12;LONG:=26;MID:=9;

DIF:EMA(CLOSE,SHORT)-EMA(CLOSE,LONG)COLORYELLOW ;

DEA:EMA(DIF,MID)COLORFF9900 ;

MACD:=(DIF-DEA)*2;

STICKLINE(OBV3>REF(OBV3,1) AND MAC3>REF(MAC3,1),0,MACD,2,0),COLORYELLOW;

吸:=XLPL.NOTEXT吸;

拉:=XLPL.NOTEXT拉;

派:=XLPL.NOTEXT派;

落:=XLPL.NOTEXT落;

STICKLINE(吸,0,MACD,1,0),COLORLIRED;

STICKLINE(拉,0,MACD,1,0),COLORRED;

STICKLINE(派,0,MACD,1,0),COLORGREEN;

STICKLINE(落,0,MACD,1,0),COLORWHITE;

入1:IF(DIF>REF(DIF,1),DIF,DRAWNULL),COLORRED,LINETHICK2;

入2:IF(DIF

低位金叉:=CROSS(DIF,DEA) AND DIF<-0.1;

STICKLINE(低位金叉,0,0.08,6,0),COLORFF00FF;

DRAWTEXT(低位金叉,0.16,' 低位金叉'),COLORWHITE;

JCCOUNT:=COUNT(CROSS(DIF,DEA),BARSLAST(DEA>=0));

二次金叉:=CROSS(DIF,DEA) AND DEA<0 AND COUNT(JCCOUNT=2,21)=1;

STICKLINE(二次金叉,0,0.06,6,0),COLORFFCC00;

DRAWICON(二次金叉,DEA*0.9,1) ;

DRAWTEXT(二次金叉,0.2,' 二次金叉'),COLORYELLOW;

A1:=BARSLAST(REF(CROSS(DIF,DEA),1));

底背离:=REF(CLOSE,A1+1)>CLOSE AND DIF>REF(DIF,A1+1) AND CROSS(DIF,DEA);

STICKLINE(底背离,0,0.03,6,0),COLOR00FF00;

DRAWTEXT(底背离,0.12,' 底背离'),COLORFF00FF;

A2:=BARSLAST(REF(CROSS(DEA,DIF),1));

顶背离:=REF(CLOSE,A2+1)DIF AND CROSS(DEA,DIF);

DRAWTEXT(低位金叉 AND 二次金叉 AND 底背离,0.25,'三全项'),COLOR0000FF,LINETHICK2;DRAWTEXT_FIX(C>O,0.01,0.9,0,' WWW.CXH99.COM '),COLORRED;

DRAWTEXT_FIX(C>O,1,1,0,'程序化交易模型'),COLORRED;

DRAWTEXT_FIX(C>O,0.01,0.9,0,' WWW.CXH99.COM '),COLORRED;

DRAWTEXT_FIX(C>O,1,1,0,'程序化交易模型'),COLORRED;

想了解更多目前A股阶段的操作技巧及公式代码,或有任何疑惑,可关注公众号越声攻略(yslc688),更多后市操作及股票技术分析方法等你来学习,干货源源不断!

成功交易系统的六个关键

1、可靠度或准确率

你的投资是 60%以上的准确率还是不到40%?

2、盈亏比

在市场上交易时你是不知道赢或输的准确概率的,另外,也不知道赢或输的确切金额,但是我们可以就自己所认可的交易系统进行历史测试并且从中获取以上两者的关键数据,虽然历史并不能代表未来,但是如果一个交易系统连历史数据都经不起考验,那么对于未来我们如何会有信心坚守这一系统。

另外历史测验的好处也在于使得我们能够看出系统在历史上连续亏损的次数、最大单笔亏损、最大单笔盈利等等一些关键数据,进而对于未来再次发生同样的事情时我们能够有所心里准备。

3、每笔交易或投资的成本。

无论是股票还是期货市场本质是都是一种负和游戏,只要你进行交易,账户规模都是一种减损。

4、获得交易机会的频率即机会因素

对于大多数优秀的交易系统尤其是趋势系统而言,真正的交易机会次数往往都会很少,这是有市场的本质决定的,毕竟趋势性的机会没有那么多次。

5、头寸规模或者资金管理

这点无论怎样强调重要都不为过,所有交易系统的核心都在于合理的资金管理。

在进入每一笔交易之前除过要事先确定好盈利或亏损时所要推出的点,其次更要确定好所要参与的量。

一次性的梭哈带来的巨额盈利当然会激动人心,但是如果你不能保证(事实上任何人都做不到)每次都会一样的准确性,那么只要又一次的失误就会断送你的投资生涯,除非你就此退出投机市场(可能吗?)。

头寸规模的控制精髓在于当你遭遇一系列打击之后,当真正的机会出现时你仍然有筹码参与其中。

6、交易——投资的规模及账户的主体

一个10000元的账户跟一个100万元的账户操作时所带来的心理影响绝不是一个量级,给自己操盘跟给别人账户操作对心理的影响绝对是天壤之别。

当你使用10000元的账户不能持续稳定盈利时,100万元的账户操作对你而言绝对世灾难而不是福音。

所以尽量使用自己的账户小规模的操作,当真正能够持续稳定盈利时才能够考虑其他因素。

(以上内容仅供参考,不构成操作建议。如自行操作,注意仓位控制和风险自负。)

声明:本内容由越声攻略提供,不代表投资快报认可其投资观点。

【免责声明】本文仅代表作者本人观点,与财富动力网无关。财富动力网站对文中陈述、观点判断保持中立,不对所包含内容的准确性、可靠性或完整性提供任何明示或暗示的保证。请读者仅作参考,并请自行承担全部责任。

0条评论

网站导航
排行
  • 日排行
  • 周排行
股票问答