当前位置:首页> 学堂>指标>MACD >正文

史上最强MACD运用口诀:“在上+正开多,在下+负开空”,字字珠玑,仅12字却受用终身

2019年12月04日 19:38:49 来源: 财富动力网综合

“MACD三+三理论”是将“绿柱缩小开始至最长一根红柱结束”作为上涨的一段(简称“正向”;从“红柱缩小开始至最长一根绿柱结束”作为下跌的一段(简称“负向”)。

“三+三理论”就是将MACD的“正向”和“负向”分别划分三个阶段(这是技术的要点!),即:

“正一阶段”(简称“正一”):从绿柱缩短的第一根开始至绿柱消失,这是涨势的启动阶段,也是上涨动力的爆发期,“平空开多”;

“正二阶段”(简称“正二”):从红柱发芽至最高一根红柱止,这里是“多单持有”;

“正三阶段”(简称“正三”):特征是红柱的柱体等高,这一阶段预示上涨行情已近尾声,这里是“准备反手做空”。

“负一阶段”(简称“负一”):从红柱缩短的第一根开始至红柱消失,这是跌势的启动阶段,也是下跌动力的爆发期,这里是“平多开空”;

“负二阶段”(简称“负二”):从绿柱发芽至最高一根绿柱止,这里是“空单持有”;

“负三阶段”(简称“负三”):特征是绿柱的柱体等高,这一阶段预示下跌行情已近尾声,“准备反手做多”。

 

行情趋势可分为五个种类,即【五大趋势】:

【上涨趋势】——是指单边向上运行(单边上涨),其特征为均线系统全部多头排列,价位在均线系统上方运行。这一趋势向上的力度最猛、速度最快、幅度最大,多数称为“飙升”。对应的“MACD三+三组合口诀”为【在上+正一】(注:“在上”即为MACD黄白线在0轴线上方;下文的“在下”即为MACD黄白线在0轴线下方。

【下跌趋势】——与上涨完全相反,是指单边向下运行(单边下跌),其特征为均线系统全部空头排列,价位在均线系统下方运行。这一趋势向下的力度最猛、速度最快、幅度最大,多数称为“跳水”。对应的“MACD三+三组合口诀”为【在下+负一】。

【反弹趋势】——这是在下跌途中的“上涨”,表面上是“上涨”,但主轨是下跌,只是因短线指标调整的需要而出现的短暂的“上涨”。其特征是“向上”的力度很弱、幅度很小、时间也很短促,接下来出现的行情多数是更为可观的下跌——这里应与真正意义上的“上涨”区分开来,可称为“反弹”,可理解为下跌途中暂时的休整。对应的“MACD三+三组合口诀”为【在下+正一】。

【下调趋势】——“下调”也叫“调整”,是上涨途中的“下跌”,主轨还是上涨。其特征是“向下”的力度很弱、幅度很小、时间也很短促,接下来出现的多数是更为明显的上涨——这里也应与真正的“下跌”区分开来,可称为“下调”,是上涨途中的休整。对应的“MACD三+三组合口诀”为【在上+负一】。

【横盘趋势】——“横盘”也叫“窄幅震荡”、“牛皮市”,是价位横向水平运行。其特征是均线系统绞缠且走势呈水平,价位在均线中徘徊(K线如骨牌水平排列),没有方向,【横盘一定不操作】。识别横盘的方法:最先表现出来的是“K线如骨牌水平排列”;后面表现出来的是均线(如5、10、20均线)相互绞缠且水平运行(经常把K线图缩小后,更明显)

“MACD操盘口诀”:在上+正,开多!在下+负,开空!

注:

在上:是指MACD的黄白线(DIFF和DIA)在0轴线上方

在下:是指MACD的黄白线在0轴线下方

在上+正一,开多!

“在上+正一”是上涨趋势,应开多持多(建议只做这个条件的单!!);

在上+正二初,开多!

“在上+正二初”仍是上涨趋势,较“正一”迟了一些,是开多的最后时点;

在上+正二,持多!

“在上+正二”仍在上涨趋势中,只持多(但在【在上+负一】后出现的【在上+正二】即出来“连体红柱”时可少量开多);

在上+负一,平多!

“在上+负一”是下调趋势,应平多观望;

在上+负二初,平多!

“在上+负二初”是下调趋势,应平多观望。

在上+负二,等待!

“在上+负二”也是下调趋势,等待下调结束后,在再次出现【在上+正一】时继续做多。

在下+负一,开空!

“在下+负一”是下跌趋势,应开空持空(建议只做这个条件的单!!);

在下+负二,开空!

“在下+负二初”是下跌趋势,较“负一”偏晚一些,是开空的最后时点;

在下+负二初,持空!

“在下+负二”仍在下跌趋势中,只持空(但在【在下+正一】后出现的【在下+负二】即出来“连体绿柱”时可少量开空);

在下+正一,平空!

“在下+正一”是反弹趋势,应平空观望;

在下+正二初,平空!

“在下+正二初”是反弹趋势,应平空观望。

在下+正二,等待!

“在下+正二”也是反弹趋势,等待反弹结束后,在再次出现【在下+负一】时继续做空。

“MACD看透主力”初始版:

1.底背离、低位金叉、二次金叉,还有双金叉(低位金叉和二次金叉)、三全项(底背离、低位金叉和二次金叉);

2.增加主力做坐庄四部曲:主力吸筹、主力拉升、主力派送和主力砸盘,主力行为一目了然;

3.把DIF线做成可以变色的线,主升浪时是红色线,主跌浪时是绿色线;

4.柱体也可以做出更多的颜色,零轴以下的不说了,零轴以上的,细分为黄金柱表买入、红柱表持有、绿柱表卖出。

“MACD看透主力”优化版:

用法:

1.主力拉升、底背离、低位金叉、二次金叉、双金叉和三全项,可以买入;

2.在0轴以上出红色MACD柱,主力拉升=1,建议持有;

3.在0轴以上出绿色MACD柱,主力拉升=0,坚决卖出。

 

 

 

 

 

 

 

 

超强MACD看透主力更新版公式指标公式源码:

VA:=IF(CLOSE>REF(CLOSE,1),VOL,-VOL);

OBV1:=SUM(IF(CLOSE=REF(CLOSE,1),0,VA),0);

OBV2:=EMA(OBV1,3)-MA(OBV1,9);

OBV3:=EMA(IF(OBV2>0,OBV2,0),3);

MAC3:=MA(C,3);

SHORT:=12;LONG:=26;MID:=9;

DIF:EMA(CLOSE,SHORT)-EMA(CLOSE,LONG)COLORYELLOW ;

DEA:EMA(DIF,MID)COLORFF9900 ;

MACD:=(DIF-DEA)*2;

STICKLINE(OBV3>REF(OBV3,1) AND MAC3>REF(MAC3,1),0,MACD,2,0),COLORYELLOW;

吸:=XLPL.NOTEXT吸;

拉:=XLPL.NOTEXT拉;

派:=XLPL.NOTEXT派;

落:=XLPL.NOTEXT落;

STICKLINE(吸,0,MACD,1,0),COLORLIRED;

STICKLINE(拉,0,MACD,1,0),COLORRED;

STICKLINE(派,0,MACD,1,0),COLORGREEN;

STICKLINE(落,0,MACD,1,0),COLORWHITE;

入1:IF(DIF>REF(DIF,1),DIF,DRAWNULL),COLORRED,LINETHICK2;

入2:IF(DIF

低位金叉:=CROSS(DIF,DEA) AND DIF<-0.1;

STICKLINE(低位金叉,0,0.08,6,0),COLORFF00FF;

DRAWTEXT(低位金叉,0.16,' 低位金叉'),COLORWHITE;

JCCOUNT:=COUNT(CROSS(DIF,DEA),BARSLAST(DEA>=0));

二次金叉:=CROSS(DIF,DEA) AND DEA<0 AND COUNT(JCCOUNT=2,21)=1;

STICKLINE(二次金叉,0,0.06,6,0),COLORFFCC00;

DRAWICON(二次金叉,DEA*0.9,1) ;

DRAWTEXT(二次金叉,0.2,' 二次金叉'),COLORYELLOW;

A1:=BARSLAST(REF(CROSS(DIF,DEA),1));

底背离:=REF(CLOSE,A1+1)>CLOSE AND DIF>REF(DIF,A1+1) AND CROSS(DIF,DEA);

STICKLINE(底背离,0,0.03,6,0),COLOR00FF00;

DRAWTEXT(底背离,0.12,' 底背离'),COLORFF00FF;

A2:=BARSLAST(REF(CROSS(DEA,DIF),1));

顶背离:=REF(CLOSE,A2+1)DIF AND CROSS(DEA,DIF);

DRAWTEXT(低位金叉 AND 二次金叉 AND 底背离,0.25,'三全项'),COLOR0000FF,LINETHICK2;DRAWTEXT_FIX(C>O,0.01,0.9,0,' WWW.CXH99.COM '),COLORRED;

DRAWTEXT_FIX(C>O,1,1,0,'程序化交易模型'),COLORRED;

DRAWTEXT_FIX(C>O,0.01,0.9,0,' WWW.CXH99.COM '),COLORRED;

DRAWTEXT_FIX(C>O,1,1,0,'程序化交易模型'),COLORRED;

MACD中最厉害的三板斧:

1、第一板斧——MACD抄底术

①经过一波下跌后反弹

②股价再次下跌创新低

 

③MACD的DIF线低点不创新低

④MACD金叉确认底背离即是买入信号

 

操作要点:MACD金叉确认底背离即可买入

2、第二板斧——MACD抓主升

①经过一波上涨后调整

②股价调整不破前低

 

③MACD在略高于0轴位置金叉

④出中阳线即买入信号

 

操作要点:MACD在略高于0轴位置金叉出中阳线即可买入

3、第三板斧——MACD逃顶术

①经过一波上涨后调整

②股价第二波上涨创新高

 

③MACD的DIF线高点未创新高

④MACD死叉确认顶背离即卖出信号

 

操作要点:MACD死叉确认顶背离即可卖出

想了解更多目前A股阶段的操作技巧及公式代码,或有任何疑惑,可关注公众号越声攻略(yslc688),更多后市操作及股票技术分析方法等你来学习,干货源源不断!

(以上内容仅供参考,不构成操作建议。如自行操作,注意仓位控制和风险自负。)

声明:本内容由越声攻略提供,不代表投资快报认可其投资观点。

【免责声明】本文仅代表作者本人观点,与财富动力网无关。财富动力网站对文中陈述、观点判断保持中立,不对所包含内容的准确性、可靠性或完整性提供任何明示或暗示的保证。请读者仅作参考,并请自行承担全部责任。

0条评论

网站导航
股票问答