当前位置:首页> 学堂>指标>MACD >正文

我在3年如何把5万本金做到了560万:全靠一招“MACD三板斧”,几乎捕捉到所有的短线上涨

2019年12月27日 01:10:10 来源: 财富动力网综合

MACD指标中文称为指数平滑异同平均线,属于大势趋势类指标,它由长线均线MACD,短期的线DIF,红色能量柱(多头),绿色能量柱(空头),O轴(多空分界线)五部分组成。它是利用短期均线DIF与长期线MACD交叉作为信号。MACD指标所产生的交叉信号较迟钝,而作为制定相应的交易策略使用,效果较好。

MACD的特性

1、当DIF和MACD的值为正值时,即均在0轴以上,属多头市场。若DIF线向上突破MACD线时,构成黄金交叉、为买入信号;若DIF线向下突破MACD时,构成死亡交叉,为回落信号,可以短线获利了结,不可以长线放空;

2、当DIF和MACD的值为负值时,即均在0轴以下,属空头市场。若DIF线向下突破MACD线时,构成死亡交叉,为卖出信号;若DIF线向上突破MACD时,构成黄金交叉,为反弹信号,可以短线回补,不可以追涨;

3、向上移动的MACD转为向下移动,DIF向下穿过MACD产生死叉,表明空方占有一定的优势。

可分为两种情况:①MACD在正位区域,即在0轴以上,此现象通常表示回档开始,可先哲时退出观望;②MACD在负值区域,即在0轴以下,此现象通常表示反弹结束,应离场现望为宜。

MACD指标有三个可以修改的参数:

快EMA和慢EMA,代表双均线的周期值,默认为12、26。MACD SMA值,代表对MACD的柱状体进行再平均的周期值。

单线MACD默认由灰色的,围绕零轴上下生长的柱状体和一根红色信号线构成。

灰色柱状体的高度和方向,表示的是默认12EMA和26EMA两根均线的差离值(DIF)。

★基本原理★

如下图,添加周期为12、26的EMA均线,红色均线周期为12,黄色为26。

对比上图,可以轻易发现,MACD的灰色柱状体的高度和方向,实际上反映的是12、26均线的垂直距离,也就是DIF差离值:

当12、26均线交叉时,柱状体高度为0;

当均线间距增大时,柱状体高度增大;

当12均线运行于26上方,柱状体为正;

当12均线运行于26下方,柱状体为负。

明白了柱状体的表示意义,那么红色信号线的意义呢?

如下图,将MACD SMA参数设置为1。

观察图表变化,发现红色信号线与灰色柱状体高度完全重合。

单线MACD的红色信号线,是柱状体值的简单平均线。

MACD四种功能

1、帮助判断底部

当股价与MACD面积(或DIF值)出现底背离时,通常预示着底部的出现,此时需要关注抄底买入的机会。

2、帮助判断顶部

当股价与MACD面积(或DIF值)出现顶背离时,通常预示着顶部的出现,此时需要考虑逃顶卖出。

3、帮助判断回调结束

股价进入多方区域后,会出现回调,回调结束后,股价通常会继续上涨或加速上涨。本书配套提供的看盘指标公式可即时显示“回调结束”信号。

4、帮助判断反弹结束

股价进入空方区域后,会出现反弹,反弹结束后,股价通常会继续下跌或加速下跌。本书配套的看盘指标公式也可即时显示“反弹结束”信号。

MACD三板斧

1、第一板斧——MACD抄底术

①经过一波下跌后反弹

②股价再次下跌创新低

③MACD的DIF线低点不创新低

④MACD金叉确认底背离即是买入信号

操作要点:MACD金叉确认底背离即可买入

2、第二板斧——MACD抓主升

①经过一波上涨后调整

②股价调整不破前低

③MACD在略高于0轴位置金叉

④出中阳线即买入信号

操作要点:MACD在略高于0轴位置金叉出中阳线即可买入

3、第三板斧——MACD逃顶术

①经过一波上涨后调整

②股价第二波上涨创新高

③MACD的DIF线高点未创新高

④MACD死叉确认顶背离即卖出信号

操作要点:MACD死叉确认顶背离即可卖出

MACD战法大全

1、MACD防狼术——(牛市炒股首要原则!)

《缠论》认为,日线图MACD黄白线运行于0轴上方,属于可操作区域。股民选择股票时,需要规避黄白线在0轴下方的股票。

2、MACD底背离——(牛市多用30分钟图MACD底背离,可以有效把握买点!)

股价阶段新低,MACD绿柱不创阶段新低,属于MACD底背离。

3、MACD顶背离——(牛市MACD顶背离效果很差,不建议使用。但在熊市和震荡市,MACD顶背离效果很好,是重要卖出信号!)

股价阶段新高,MACD绿柱不创阶段新高,属于MACD顶背离。

4、MACD黄白线0轴长飘——(MACD黄白线长期贴近0轴运转,是主力吸筹、洗盘的表现,投资者遇到这类股票,可重点关注!)

MACD黄白线长期贴近0轴运行,一旦向上发散,则股价向上爆发力度很强!

5、MACD空中加油——(MACD空中加油在牛市很常见,一旦出现,通常有持续上涨!)

股价上升趋势下,MACD出现一片大红柱。股价进入调整后,MACD红柱减小。但随后股价出现放量阳线,把MACD的红柱再放大,此时属于MACD空中加油,仍继续看涨!

6、MACD三点绿——(MACD飘绿不是好事,但只飘不到3点绿,再次放量上攻,出现红柱的,就是强庄上攻!)

股价维持一段上升趋势后,出现调整,但MACD绿柱仅出现不到3根绿柱,再做放量上攻的,股价继续上涨!

7、MACD鳄鱼嘴——(很多牛股的启动形态都是MACD鳄鱼嘴,并且此形态也可应用于30分钟图)

MACD黄白线在0轴附近出现鳄鱼嘴形态的,继续看涨!

8、MACD黄白线0轴上方第一次金叉——(黄白线在0轴上方第一次金叉的准确率最高!)

MACD黄白线在0轴上方的第一次金叉,是买点!

9、MACD黄白线0轴下方第一次死叉——(黄白线在0轴下方第一次死叉,股民务必将股票脱手)

MACD黄白线在0轴下方的第一次死叉,必须卖出!

“MACD看透主力”初始版:

1.底背离、低位金叉、二次金叉,还有双金叉(低位金叉和二次金叉)、三全项(底背离、低位金叉和二次金叉);

2.增加主力做坐庄四部曲:主力吸筹、主力拉升、主力派送和主力砸盘,主力行为一目了然;

3.把DIF线做成可以变色的线,主升浪时是红色线,主跌浪时是绿色线;

4.柱体也可以做出更多的颜色,零轴以下的不说了,零轴以上的,细分为黄金柱表买入、红柱表持有、绿柱表卖出。

“MACD看透主力”优化版:

用法:

1.主力拉升、底背离、低位金叉、二次金叉、双金叉和三全项,可以买入;

2.在0轴以上出红色MACD柱,主力拉升=1,建议持有;

3.在0轴以上出绿色MACD柱,主力拉升=0,坚决卖出。

 
 
 
 
 
 
 

超强MACD看透主力更新版公式指标公式源码:

VA:=IF(CLOSE>REF(CLOSE,1),VOL,-VOL);

OBV1:=SUM(IF(CLOSE=REF(CLOSE,1),0,VA),0);

OBV2:=EMA(OBV1,3)-MA(OBV1,9);

OBV3:=EMA(IF(OBV2>0,OBV2,0),3);

MAC3:=MA(C,3);

SHORT:=12;LONG:=26;MID:=9;

DIF:EMA(CLOSE,SHORT)-EMA(CLOSE,LONG)COLORYELLOW ;

DEA:EMA(DIF,MID)COLORFF9900 ;

MACD:=(DIF-DEA)*2;

STICKLINE(OBV3>REF(OBV3,1) AND MAC3>REF(MAC3,1),0,MACD,2,0),COLORYELLOW;

吸:=XLPL.NOTEXT吸;

拉:=XLPL.NOTEXT拉;

派:=XLPL.NOTEXT派;

落:=XLPL.NOTEXT落;

STICKLINE(吸,0,MACD,1,0),COLORLIRED;

STICKLINE(拉,0,MACD,1,0),COLORRED;

STICKLINE(派,0,MACD,1,0),COLORGREEN;

STICKLINE(落,0,MACD,1,0),COLORWHITE;

入1:IF(DIF>REF(DIF,1),DIF,DRAWNULL),COLORRED,LINETHICK2;

入2:IF(DIF

低位金叉:=CROSS(DIF,DEA) AND DIF<-0.1;

STICKLINE(低位金叉,0,0.08,6,0),COLORFF00FF;

DRAWTEXT(低位金叉,0.16,' 低位金叉'),COLORWHITE;

JCCOUNT:=COUNT(CROSS(DIF,DEA),BARSLAST(DEA>=0));

二次金叉:=CROSS(DIF,DEA) AND DEA<0 AND COUNT(JCCOUNT=2,21)=1;

STICKLINE(二次金叉,0,0.06,6,0),COLORFFCC00;

DRAWICON(二次金叉,DEA*0.9,1) ;

DRAWTEXT(二次金叉,0.2,' 二次金叉'),COLORYELLOW;

A1:=BARSLAST(REF(CROSS(DIF,DEA),1));

底背离:=REF(CLOSE,A1+1)>CLOSE AND DIF>REF(DIF,A1+1) AND CROSS(DIF,DEA);

STICKLINE(底背离,0,0.03,6,0),COLOR00FF00;

DRAWTEXT(底背离,0.12,' 底背离'),COLORFF00FF;

A2:=BARSLAST(REF(CROSS(DEA,DIF),1));

顶背离:=REF(CLOSE,A2+1)DIF AND CROSS(DEA,DIF);

DRAWTEXT(低位金叉 AND 二次金叉 AND 底背离,0.25,'三全项'),COLOR0000FF,LINETHICK2;DRAWTEXT_FIX(C>O,0.01,0.9,0,' WWW.CXH99.COM '),COLORRED;

DRAWTEXT_FIX(C>O,1,1,0,'程序化交易模型'),COLORRED;

DRAWTEXT_FIX(C>O,0.01,0.9,0,' WWW.CXH99.COM '),COLORRED;

DRAWTEXT_FIX(C>O,1,1,0,'程序化交易模型'),COLORRED;

想了解更多目前A股阶段的操作技巧及公式代码,或有任何疑惑,可关注公众号越声攻略(yslc688),更多后市操作及股票技术分析方法等你来学习,干货源源不断!

(以上内容仅供参考,不构成操作建议。如自行操作,注意仓位控制和风险自负。)

声明:本内容由越声攻略提供,不代表投资快报认可其投资观点。

【免责声明】本文仅代表作者本人观点,与财富动力网无关。财富动力网站对文中陈述、观点判断保持中立,不对所包含内容的准确性、可靠性或完整性提供任何明示或暗示的保证。请读者仅作参考,并请自行承担全部责任。

0条评论

网站导航
股票问答